Cannot open one of my pages anymore

WHAT IS THE BUG

When I click on a page to open it, this specific page is not able to open. All others are working. On my laptop nothing is happening, and when I try to open this page on my anddroid phone the app is even crashing.

HOW TO REPRODUCE IT

  1. Start Anytype
  2. Click on a page to open
  3. Nothing happens

THE EXPECTED BEHAVIOR

The page should open like all others do.

SYSTEM INFORMATIONS

  • OS:
    Windows 11
  • Device:
    Dell G15
  • Anytype Version:
    0.29.1

Do you happen to remember some of the details of that page? Like, what object type, what kind of Blocks,number of blocks.

Have you tried clearing the cache and allowing it to download from the central node again, in case the local file has corrupted?

it was just a page with some check boxes and headings

How can I do that? not a pro

Go to the top right hand corner, select anytype and then settings. From that pop up screen, select account and data and finally clear file cache. Close and reopen the application.

Now I did what you suggested. Unfortunately the bug is still present.

Do you just anytype on any other devices? If so, are you able to open this object there?

on my android phone, at first I was not able to open it there too, but a few days ago it just worked and is working till now. I don’t really get that.

@NiKu try now cloning (duplicating) the object on the android device and see if the new object is accessible.

1 Like

Just to note, I am not suggesting this is a fix or explanation, but if it works then it means it is object specific. If not, it might be more to do with the contents of the object vis a vis the desktop app.

1 Like

I did that and on my phone everything works fine but now when I open the anytype app on my laptop, anytype crashes instantly so now I cannot see any pages at all :face_with_spiral_eyes:

In this case, on the desktop with the app closed, make a copy of the Data folder in the app’s installation directory (for me this is: C:\Users[enter your username here]\AppData\Roaming\anytype2\data) and try restarting the app. My understanding is it will recreate the data files by downloading, hopefully, the good files from the remote node. If it fails to start, uninstall the app removing local files and reinstall, logging back in with your passphrase (for which you still have accessible on your phone).

1 Like

Do you have any important or personal information stored in the object? I think the most efficient course of action would be to get the debug logs and send it to the developers (probably before you rename the directory like Lloyd suggested - it might solve the problem for you but not allow the developers to fix the bug), seeing that your object doesn’t work for both Desktop and Mobile.

You might want to follow this official process for debugging and sending the logs to the developers: Sync problems, White screen or not responding, high resource consumption - #3 by Vova , specifically starting from " If there is no crash, we need to also check if we have some errors in the JS console"

I also believe that there is also a new “Current object debug” option in the latest version – it should be in “File → Current Object Debug” in the top toolbar. You may want to zip then send the entire folder Anytype generates to the developers.

Once you get the logs sent over to the developers privately at support@anytype.io, I’ll add the “Triage” tag to indicate that it’s ready for the developers to take a look at.

2 Likes