Cannot login to AnyType 0.27.0 Windows Client

Describe the bug
Cannot Login to Anytype 0.27.0 windows client

To Reproduce
Uninstall anytype
install fresh copy of anytype 0.27.0
login using your pass-phrase
nothing happens …

Expected behavior
successful login and syncing my old data

System Information:
Windows 10 x64 Pro
Anytype 0.27.0 client

Additional context
I used to goto settings ==> Account settings and clear cache. This usually helps in old versions like 0.25.0 and 0.24.0 However, there is no Account settings in 0.27.0 version.

1 Like

Hi @mnasim! Is it possible to get the “tree diagnostics”? I hope that menu item is available even though you cannot login.

image

1 Like

Hello @sambouwer, I see “tree diagnostics”, but there is no output of it.
It seems that it does not do anything.

Guys, it is Friday late, and i cannot login since Wednesday. :smirk:

Are you able to use another device like iPhone, iPad, Android smartphone/tablet to try to login from there?

Fortunately, i am already logged-in on my Android phone. However, some blocks are not editable on android such as LaTeX. Moreover, even normal blocks are easier to edit from PC.

That’s great to hear! Can you check if everything is synced? If so, maybe it helps if you try to download and install an older version of Anytype, then login and then upgrade? I’ll see if I can find an older installer on my laptop or maybe in the Telegram group.

My Android device is synced. However, installing 0.25.0 does not help, even after clearing file cache.
Installing fresh Windows will be so painful.

Having the same issue. Also not able to view few pages in my android app.

Sounds like you tried quite a lot already. By clearing the cache, do you mean the Anytype2 folder in the Roaming folder on Windows? If so, I’m not sure if there is any other Anytype related data we have to remove apart from that one.

For reference, I’m linking a similar issue described here:

Hello Sam,
Yes!! i mean the folder in %appdata%\rooming folder, in case you want to delete them manually. Also, you can achieve the same result by going to Settings => Account Settings => Clear File Cache.

The attached reply “checking if port numbers are allowed” does not help, because i have already all ports allowed and there is no proxy. However, i have the same problem, that is Application Stuck in Login Screen

2 Likes

Try going to App Inrfo and Force Stop your AnyType.
Open it again, and it may help viewing old pages.
I always do that, and it helps alot

Guys, I have a painful solution to this problem, but it is a solution.
Install VMware
Install Windows7 Virtual machine
Run Anytype 0.27.0 inside your VM
that is it. Now, you can login.

Try to copy %appdata%\anytype2 from Windows7 vm to your Windows 10 machine and you will gain nothing. Things still not working.

So far, i can access my notes from Virtual Machine. :grin:
am i the only one who thinks that Windows7 is too much better than Windows10?

  • Thank me :slight_smile:
  • I am welcome :slight_smile:
1 Like

Now that’s a Workaround with a capital W! Could you share both the broken and the working Anytype2 folder? Not sure what the best place is to send it to (maybe support@anytype.io) but that would make a diff possible!

1 Like

Finally, I found the problem.
It is not about Network ports whether allowed or not.
It seems that my antivirus Kaspersky Internet Security cannot trust the application.

The problem only appeared since 8/7/2022 (dd/mm/yyyy), although I use Anytype before that date.

Steps to solve the problem

  • Quit your Kaspersky Internet Security software
  • Run Anytype 0.27.0 and login
  • Sync your data
  • Turn your Kaspersky back ON

Very strange behavior. could you guys contact Kaspersky Labs !!

Here is the complete log:
kaspersky-Anytype-Conflict.zip (1.5 KB)

3 Likes

Thank you so much for your elaborate investigation! Let’s leave this bug report open for the Anytype team to acknowledge.

2 Likes