Cannot access cover options when the page is opened in a modal

Describe the bug
When a page is opened as a modal from a set view, on clicking the cover button, in the cover popup, the buttons to change or reposition the cover goes outside the view making it impossible to select them

To Reproduce
Steps to reproduce the behavior:

  1. Go to a set with several pages
  2. Scroll down
  3. Click on a page to open it as a modal / popup
  4. Click the cover button

Expected behavior
The cover options should be completely visible and accessible to the user

System Information:

  • OS: Fedora Silverblue
  • Anytype Version: 0.21.1

Additional context
The issue does not happen when the set view is not scrolled. It occurs only when the set view is scrolled.


Video of the issue in the same page opened with and without scroll from a set

@lynxlove Hi! I can’t repeat this. Which type of layout do you use? And I see that your page has center alignment. Does it reproduce only with this mix of parameters or is it independent?

The page is using the basic layout

I’ve tried the same with right, left & center alignment and the issue is reproducing in-spite of the the alignment of the title and icon.


The exact prerequisites to reproduce the issue is to have:

  • A page with a cover
  • A set of a type the page belongs to. The set should have several pages to enable scroll

After ensuring the above, open the set, scroll down, open any page and click the cover button :smile: The issue is reproducing only after scrolling in the set, without scrolling, the cover button works properly.

@Kirill_Lem Can you reproduce the issue now? :grinning_face_with_smiling_eyes:

If it helps, I cannot reproduce it under Windows, so it seems to concern only Linux.

@lynxlove Unfortunately not. I was trying on Ubuntu, but the cover menu worked properly. Looks like it’s Fedora-related behavior. We will try to do something with it.

I’ve tried it on X11 and its the same. Since you cannot reproduce this on ubuntu, I suspect then this might because of the display resolution.
My laptop’s display resolution is: 1366x768
Anytype’s Viewport:

  • window.innerWidth: 1326
  • window.innerHeight: 706

Thank you for info, I will try with this params

1 Like

@lynxlove I can reproduce this. But only if I my window size is under a specific width and height and only when I scrolled in the set list. How did you found that the first time :sweat_smile: ?

The change cover popup seems to be reworked in 0.24.0. This issue is not reproducing anymore.Marking it as solved