Bug Reports- Blank Page after logging in

Describe the bug
A clear and concise description of what the bug is.
After logging on, blank page appeared
To Reproduce
Steps to reproduce the behavior:

  1. Go to ‘…’
  2. Click on ‘…’
  3. Scroll down to ‘…’
  4. See an error

Expected behavior
Fix the bug

System Information:

  • OS: Mac OS Desktop
  • Device Manufacturer/Model: e.g. Macbook Air 2020, M1
  • Anytype Version: Not sure, should be the most updated version, I can’t access to any part of the ap

Additional context
I can’t quit the app normally, it doesn’t work to use shortcuts like Command+Q to quit Anytype.

Could you check whether the issue is the same as the one described here? (white screen)

I followed the instructions but it showed as command not found, pls. see as below:

I’m not sure if the “%” (percent) sign is part of your command, because according to the support post it should start with ANYTYPE_LOG_LEVEL. Apart from that, I think the second command should be a separate command. Seeing your print screen, it looks like you pasted everything on the same line/in a single command. Finally, please double check whether the location that is provided as an example matches the location where Anytype is installed on your Mac.

Try the following sets of commands then

  1. Set the ANYTYPE_LOG_LEVEL environment variable
    export ANYTYPE_LOG_LEVEL="* = DEBUG"

  2. Make sure the value is added to the shell
    printenv ANYTYPE_LOG_LEVEL
    The above should display the value set in the first step

  3. Start anytype using the following command
    /Applications/Anytype.app/Contents/MacOS/Anytype

After which, Kindly follow the instructions mentioned in the link shared by @sambouwer

Hi Sam,
I followed the White Screen post instructions, how can I send debug log to your team?

Thanks, but it seems a little complicated for me.

Hi @Doohah, I’m just another alpha user, I’m not part of the Anytype team ;).
After starting Anytype with debugging enabled in the terminal window, you should be able to copy the output from the terminal window using CTRL-A (to select everything) and CTRL-C (to copy), and send it to the team at support@anytype.io.

Hi Sam,
Many thanks for your kind help. I’ll try and send it out for further solutions.

1 Like

Once you’ve been able to get the bug report saved and sent out, can you try deleting the “cache” folder in the Anytype work directory? I’ve also encountered the same issue (white screen after login, also on M1 MacBook Air) three times, and I believe deleting that folder may fix the issue and allow you to get back into using the app.

Otherwise, if that doesn’t work, please try deleting the entire ‘anytype2’ folder.

Also related issue: Just downloaded, open to blank screen . Do you want to merge this post?

@edwards Thanks for your reply. I’ve tried to find anytype2 folder, but I can’t find it. I once deleted the Anytype app and installed the newest version. Can you tell me where can I find the folder? Many thanks!

1 Like

It finally works now, go to finder and find press “Go”, then long press “option” button, the hidden folder “Library” will be shown. Go to the /Library/Application Support folder, find anytype2 folder and remove it (Back up the folder in case of data loss, if data is not synced correctly, we can get the anytype2 folder back).

3 Likes

@Doohah great to hear! Can this topic be marked as resolved?

I think it’ll be best to merge the parent post (not the replies - that’s too much!) with another issue about the blank-screen issue, as this issue still appears to occur occasionally and isn’t fixed.

While this post isn’t exactly detailed, it still does provide important information about the device and circumstances where the issue occurred - it’s probably best to edit this a bit to remove the sample text and merge it back into the aforementioned post. Any thoughts?

@sambouwer Sam, this works finally, you can mark it as resolved. Thanks for your help.

1 Like