Bold and italics display irregularly on iOS

Describe the bug
Sometimes, a word that was set to bold or italics on another device (Windows mostly) doesn’t display correctly on iOS. The formatting starts with a missing letter or ends with a few extra letters.
image
image
image

To Reproduce
It is hard to reproduce because it only happens sometimes. Right now I can’t reproduce it. iOS 15.2, app version 0.7.0.

I tried using bold and italic styling on the Desktop app while having the app open.
The style is not always instantly applied on mobile (sometimes only after entering a new line) but then it seems to look good. Do you still have this bug?

Yes it’s still there, but it doesn’t happen often. Maybe there’s a bug on the ios markdown editor that misaligns bolds and italics under some circumstances, but I don’t know what they are.

Hey, i tried some typing on the desktop with my phone open and everything seems to be displayed correctly in 0.11.0.

The only “issue” I see is, when I type something in markdown on pc, it instantly shows on the phone, but in the markdown notation. Only when I press enter on pc it gets converted to markdown on the phone.