Blank profile picture / avatar (here on the forum)

One of the first things I do when joining a Discourse forum is to write a bio and add a profile picture.

But in the anytype community Discourse forum, I cannot get this to work.

Gravatar

I tried selecting the Gravatar option first, since I have a Gravatar/WordPress account with images. I’ve (literally) quadruple-checked that I’m using an email address for this forum that my Gravatar account knows about. Everything seems to be set up correctly, but I see only the ghostly gray icon that Discourse uses when there’s no image.

Uploaded image

So I’ve tried uploading images. There are a few I usually choose, and I have tried all of them. The upload works fine, and Discourse actually shows me the image that I uploaded. But when I click “Save,” I’m still looking at that ghostly gray avatar.

I have tried multiple browsers. I have deleted my browsers’ caches and reloaded forum pages with fresh, non-cached assets. Nothing.

I see lots of other people’s avatars, but not my own.

As I have things set now, the image should look like this:

but what I see is: Screenshot 2022-12-16 at 12.27.29

Any ideas?

1 Like

there might be some issue with image uploads, as I read someone else is having trouble adding images to a post…

@Angelo anything you can see in the Discourse logs maybe?

Edit: see other recent mentions of not being able to upload images:

3 Likes

The image uploading issue was unrelated. Profile pictures not loading is a new problem. I’ve been trying to resolve it for several days now. Thanks for reporting @ErikMH

3 Likes

I’m just happy to learn it isn’t me. :slightly_smiling_face: Thanks for working on it….

2 Likes

I am having the same issue right now. The website is not displaying the profile picture from Gravatar or the uploaded image.

2 Likes

Same here!

3 Likes

So sorry about this everyone! I’m very aware and bothered by it as well. :melting_face:

Discourse is self-hosted, meaning the docker (forum software) lives on our node and is browser accessible via 3rd party web/domain-host. A month or so ago there was an image certification problem on the web-host side that prevented images from loading in our posts, so we made an override quick-fix on our end to resolve it. Unfortunately this kicked the problem down the road, as we suspect the quick-fix caused a conflict with the custom profiles pics :man_facepalming:
It’s not such a huge puzzle to repair, but the only team member who can do it has a task list a mile high. It should be done soon though. Thanks once again for your patience.

7 Likes

This has been fixed.

3 Likes