Backup node is stuck in Syncing… status when uploading a file

WHAT IS THE BUG

I only notice it when I try to access a file I attach in my home pc to my work laptop and the file wasn’t opening/downloading. It’s been stuck for many days
image

I’ve also notice that one of the pages has a status of Uploading = 1 and Stored = 4 but there are only 3 files attached to that page. I’m not sure if it is related that my upload queue is stuck.
image

I hope we could have these promised features for sync in near releases:

  • Sync Control Options
  • The Precise status of each Object
  • The Naming of Sync Devices
  • Ability to toggle sync for specific pages and objects

HOW TO REPRODUCE IT

  1. Create a page
  2. Attach a file
  3. The status would be stuck to Syncing… and File status would be stuck in Uploading

THE EXPECTED BEHAVIOR

The file would be uploaded to backup node.

SYSTEM INFORMATIONS

  • OS:
    Windows 11 22H2
  • Device:
    PC
  • Anytype Version:
    0.29.1

ADDITIONAL CONTEXT

Anytype.exe and anytypehelper.exe is not blocked in firewall and all of it’s ports are open.
I’m also not using any VPN or any program that modifies my internet connection.
I’ve also tried this on different devices. It would sync locally but not on the backup node.

Anytype ID: A5xWQnWdmB9B8jRVag9n2nK8MRcWkkdCucbAQyJ8S8XyAVwE

1st issue - Account Debug and Object ID
debug.zip (94.9 KB)

2nd issue - Account Debug and Object ID
debug.zip (317.1 KB)

2 Likes

Hi,

I just to want to add up on this.
I don’t know if this is related to this but I tried logging in on another device and this happen to my pages.

It’s been stuck for almost half a day.

Hi, I just want to check on this since it’s still happening and now it’s worst.
Every time i create a page and add a photo icon/cover, the page would also stuck on Syncing… too

Hi @lacno29, could it be you are located in a country where internet access is not as open as you’d like? As there are not many others posting about this issue, it seems to be an issues with your internet connection, either your local network or your ISP.

1 Like

Hi @sambouwer, that is my initial thought too that my ISP is the problem. But I tried to use 3 different ISP (Home internet/Mobile Data/Work Network) and all of them produces the same issue.

I live in the Philippines by the way and Im not sure but the internet access here are open. I think…

1 Like

Hi @lacno29 , does this happen only when you’re dealing with files? I get all kinds of sync issues and I’m also from the Phils. I wonder if it’s our country’s internet connection. :thinking:

I don’t think this is a singular case, though, as there have been a couple of sync issues reported already. I know they’re working on it, but there’s been no new update regarding its status, as far as I know.

Hi @Kerstie, yes this only happens exclusively to files. All object/blocks/pages are fine and synced to backup nodes. I could also download existing files that I’ve already synced on the backup node but I could never upload new files. I’m starting to think that this issue is tied on my account as @sambouwer said that not many people reporting this issue and I’m positive that my internet connection is fine.

Yes. I know they’re working on it, but since this is an isolated case and not many other people reporting on it, it may take time before they could give an update. Which is understandable.

1 Like

Hi, can I ask for any update regarding this issue? Any workarounds or troubleshooting steps?
I’m having a hard time now using Anytype without a backup node. Thanks

This report has been added to our issue tracker and received by the Development Team.

1 Like

“Syncing” status is not available in the app anymore. Syncing got a whole new view since then.