Application not starting in Linux RedHat derived distribution

Describe the bug
I tested the application in Rocky Linux 8.5 (an exact clone of RedHat 8.5) and it fails to start.

To Reproduce
Steps to reproduce the behavior:

  1. execute the application from command line
  2. the main window shows up but it is empty (white). Only the toolbar shows up, and in the console I can read the following error message:
10:12:46.268 › Config: {
   "channel": "latest"
Config: {
   "channel": "latest"
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
[17661:0318/] InitializeSandbox() called with multiple threads in process gpu-process.
Channel:  latest
(node:17619) UnhandledPromiseRejectionWarning: Error: An object could not be cloned.
    at EventEmitter.t.ipcRendererInternal.send (node:electron/js2c/renderer_init:85:328)
    at EventEmitter.<anonymous> (node:electron/js2c/renderer_init:81:357)
(Use `anytype2 --trace-warnings ...` to show where the warning was created)
(node:17619) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see (rejection id: 1)

after that the menu is responsive, but nothing works as expect, even the quit command closes the UI but the program is left running and needs to be terminated with a double CTRL-C.

Expected behavior
The app starting.

System Information:

  • OS: e.g. Rocky Linux 8.5 (RedHat clone) - Kernel: 4.18.0-348.7.1.el8_5.x86_64
  • Device Manufacturer/Model: custom built PC (CPU AMD Ryzen 3700X)
  • Anytype Version: e.g. 0.24.0

Additional context
On the same hardware, in dual boot, with Ubuntu the application works correctly.

Hey @Aleph1,
is this still the case with 0.25.4?

yes, still not starting

I did a new test after updating to Rocky 8.6 clone of RHEL 8.6 and still get the same.
I added

export NODE_DEBUG=cluster,net,http,fs,tls,module,timers

to the enviroment to collect some node log.
To long to quote I attach it.
anytype_0.25.4_start.log.pdf (121.7 KB)

The problem is still present in 0.26.1

1 Like

@Aleph1 Thank you for report! I added the bug to our tasks tracker

1 Like

@Aleph1 looks like you have some problem with video driver on your distr, maybe this driver doesn’t support acceleration."va_getDriverName()+failed+with+unknown+libva+error%2Cdriver_name"&newwindow=1&client=safari&rls=en&sxsrf=ALiCzsZhY3KgzIxBfzq9A7_xjG6AZoYo9w%3A1660821845871&ei=VSH-YvPSNMrysAfLlKKABw&ved=0ahUKEwiz0aHBo9D5AhVKOewKHUuKCHAQ4dUDCA0&uact=5&oq="va_getDriverName()+failed+with+unknown+libva+error%2Cdriver_name"&gs_lcp=Cgdnd3Mtd2l6EAMyBwgAEEcQsAMyBwgAEEcQsAMyBwgAEEcQsAMyBwgAEEcQsANKBAhBGABKBAhGGABQAFgAYOYIaAFwAXgAgAEAiAEAkgEAmAEAyAEEwAEB&sclient=gws-wiz

Hey @Aleph1,
do you had a look at the provided resource?
Was the issue resolved?

Closing the topic because there is no response. Please open a new topic or flag this one to be reopened if you still experience this issue.