AppImage Crashes Immediately

Describe the bug

When running the appimage a javascript exception is thrown immediately on start up

To Reproduce

Steps to reproduce the behavior:

    1. Execute app image from terminal

Expected behavior

AnyType destop app should open up to home screen dashboard


OS: Ubuntu

Device: Lenovo IdeaPad

Version: 20.04.03

Additional context

When I run the appimage the app immediately crashes without ever opening and throws the following exception:

@gelinasj HI! I launched the app using this guide, and everything is ok.

    1. Open a terminal
    1. Change to the directory containing the AppImage, e.g., using cd <my directory>
    1. Make the AppImage executable: chmod +x my.AppImage
    1. Run the AppImage: ./my.AppImage

Can I guess that you made a mistake when you write a path to Anytype?

@Kirill_Lem Can you clarify what you mean by “write a path to anytype”? I am still having the issue mentioned above

Hey I just wanted to follow up if I could get some help @Kirill_Lem

@gelinasj by “write a path” @Kirill_Lem means the installer location of the .appimage

Hmmm, is there a specific location the appimage needs to be? Could I get some further clarification how this might be leading to my issue? To me it seems more an issue with the app because it worked when I first opened it, then any time after that is throws this error on start up and won’t allow me to proceed.

@gelinasj You may be right, it was not clear from your initial report that it had ever worked, so that may indicate something else. But just to be sure, if you are a member of the Desktop Testers Telegram group, if you search for “linux path” there, you will find some discussions that may be related or helpful.

@gelinasj Hi! Very sorry for the long answer! No, it isn’t specific loaction. It could be any directory where your AppImage is. And I forgot to ask, if you launch the app by click on the anytype file does it launch?

1 Like

I have the exact same problem. The package used to work fine, but for a while, it crashes and emits the same error dialog.
I’ve tried launching directly as well as via command line. Both used to work, now they don’t.
I’ve also uninstalled-reinstalled, rebooted, and still facing the same issue.

This continues to happen to me as well

@gokussjx @gelinasj is this stil happening on the latest version of Anytype? (0.25.4 at the time of writing)

No, it seems to have resolved itself.
Clean wipe and reboot + reinstall fixed it for me.

1 Like