App goes white and unresponsive when unknown typed object is opened

Describe the bug
One custom type I created, named “Configurations” is not getting synced to the desktop app. This type was created long back and there are few objects of this type. The objects are properly synced though. I have a set of that type and it is synced as well. When I create a new object of that type through the object creation option in set, a new untitled page of a unknown type is created since the type is not available in the desktop app. When the object is opened, the app goes white and unresponsive and can only be solved by restarting the app. The type is available in the android app and is properly working

To Reproduce
I’m not sure if you guys can reproduce the issue, but once you have a set of unknown type, the following are the steps to reproduce the behavior:

  1. Go to the set of that unknown type
  2. Click on the new object button
  3. Open the newly created object

Expected behavior

  • The custom type should be properly synced
  • Opening a page of unknown type should not crash the app and should fallback to a blank page with no type

System Information:

  • OS: Fedora linux
  • Anytype Version: 0.22.3

Additional context


Type of the pages of that type


Screen recording of the issue


Opening the set in the android app displays the type properly


Opening the newly created object in the android app displays the page without the type


Creating a new object of the type from the android app directly properly displays the type in the new page

@lynxlove Hi! It has to be fixed in the new version. I can’t reproduce it. Please, check it in your devices and write if it’s ok

1 Like

I’ve created a new type with the same name and it is now synced so not sure if this is reproducing again. I’ll mark it as solved now and will reopen if this ever happens again. Thank you :grinning:

1 Like

I just saw today I have an Untitled type in my type list. I’ve tried to reproduce the issue by opening the type, it keeps loading for about a minute and the modal closes instead of making the app unresponsive. Looks like the issue has been fixed. Thanks a lot :grinning:


There is still the untitled type available for me, I can create new pages of that “Untitled” type and can even create a set of them.
Set of relation is empty for that set and Object type is also empty for that type. Kindly let me know if you need object / tree diagnostics to check, I’ll dm them tomorrow