Anytype won't open on M2 Mac

WHAT IS THE BUG

ᅟAnytype won’t open on new M2 MacBook Air running Ventura

HOW TO REPRODUCE IT

  1. Click on icon to open Anytype.
  2. Receive the following error message: “Error: failed to run server”

Screenshot 2022-11-15 at 9.22.10 AM

  1. Click OK
  2. Anytype remains open (per menu) but window not visible/content not accessible
  3. Click on Anytype in menu bar
  4. White window appears

SYSTEM INFORMATIONS

  • OS:
    Mac OS Ventura 13.0.1
  • Device:
    MacBook Air M2 (2022)
  • Anytype Version:
    V.0.29.1
1 Like

Hi @kayzee Welcome to the Community and thanks for your post.

Are you attempting to connect over a VPN or unique network configuration by chance? Like at work or school?

If so, please try without a VPN or from another network, such as hotspot from mobile. If that doesn’t work, you can also try uninstalling, downloading again and reinstalling Anytype.

Also, have you already set up an account or is this your first time trying to redeem your invite code?
If so, please try to setup your account from your mobile device and then log in on desktop after you have a Recovery Phrase.

This report has been added to our issue tracker and was received by the Development Team.

Hello!

No VPN, just using it on my own laptop.

I set up an account previously on M1 MacBook Air, and am able to get logged into my account on iOS.

Reinstalling from your link worked - it prompted for my passphrase as expected and is currently syncing. I had tried reinstalling before but I was using the link that was emailed to me when I received my Alpha invite - it’s possible I had hit a maximum number of downloads from that link?

In any case, issue resolved, and thank you for your help!

1 Like

That’s great to hear, thank you for following up! Happy Anytyping :computer: :milky_way: