Anytype taking 2-5 Minutes to get past the logging in screen

The login screen always takes more than 2-3 mins for me in the desktop app and sometimes more than 5-10mins. This is not specific to the latest version and it happens for me in any version of Anytype I’ve tried so far. I thought of asking if that’s the case with everyone as well, i.e. to check if it is the intended behavior, before raising as an issue. It would be great to know the login time along with your device details.


OS: Fedora Silverblue / Linux
Memory: 8GB
Processor: i5-4300U CPU @ 1.90GHz × 4
GPU: Intel HD 4400
Time taken to load: At least 3 mins
Storage type: Integrated HDD
Number of objects: 344 objects (can be found by Square menu → Relation tab → Creation date)
Size of anytype2 folder: 696.6 MB

Time-lapse video of login:


If by chance that this is the intended behavior, it would be great to reduce the delay to login in the desktop version. The app is snappier once I get past the login screen though :smile:

3 Likes

Here’s my experience with using Anytype. Seems like more data is needed to determine if long load times are Linux or HDD-specific.

OS: MacOS 12.1
Memory: 16GB
Processor: Apple M1
GPU: Integrated Apple M1 (7 cores)
Time taken to load: Approximately 7 seconds

Here’s some information that you haven’t included in your initial template, but may also be useful for figuring out details about this issue:

Storage type: Integrated SSD
Number of objects: 650 objects (can be found by Square menu → Relation tab → Creation date)
Size of anytype2 folder: 1.98 GB

2 Likes

My observations regarding the login time for Anytype:

It took 16 seconds with and without internet the first time I tried it. I had multiple browser opens, a design software and iMovie open at the time of test.

I shuttered down my laptop and launched Anytype the first thing after launching the laptop and it returned 12s the first time and 10.7s the second time.

Processor: Dual-Core Intel Core I-7
Memory: 8GB

Storage type: SSD

1 Like

Thanks for the inputs @Srinath, @edwards & @abheek , appreciate the help :smile: I’ll move this to a bug report now.


Adding more videos showing the behavior with and without internet:

Without Internet:

With Internet:

As you can see in the video, the time taken for anytype to get past the login screen with internet is a whooping 5 mins :slightly_frowning_face:

Network Speed for reference:

Mine with not doing any new changes took around 30-32 seconds with and without internet. - first opening

Will check with any major addition and see.how long it takes

yeah i am on Zorin OS
i have nvme SSD …still the anytype application takes more than 30 seconds to load. Not just first time after boot but everytime I launch the application

To add on,

I recently updated to latest MacOS build and these are the new timings I observed:

with internet: 12 secs
without internet connection: 14 secs

I did a RAM clean up and after that I observed the login time, with internet to be: 10 secs

Loading time (Internet enabled): ~8 seconds
Loading time (Internet disabled): ~13 seconds
Anytype version: 0.21.5 | Desktop
Objects count: 244 objects
Size of anytype2 folder: 78MB
OS: Windows 10
Memory: G.Skill 12GB | DDR3 | 3200Mhz)
Processor: Intel Core i7 960 | 3.20Ghz | 4 cores/8 threads
GPU: Discrete graphics card | Nividia GeForce GTX 1050 | 2GB
Storage: Samsung SSD | 40GB of free space

I tried Anytype on a Windows VM with Gnome Boxes today and the worst opening time was around 30sec with internet enabled and the average is around 8-12sec with Internet enabled. On the linux host, Anytype still takes around 3-5mins to open with internet enabled :man_shrugging: I’m quite surprised by this extreme difference even when the app is ran on a Windows VM on the same hardware
RAM Allocated to VM: ~4GB
Storage Allocated to VM: ~80GB
CPU: 4

1 Like

The app is opening under 10sec after the latest update, i.e. 0.22.1 :tada: Thanks a lot for the efforts. I’ll mark this as solved after checking it for a day or two

2 Likes