Anytype helper crashed - bug


Desktop app crashed during normal usage while in the background.


Undetermined. It has not crashed while I’m actively using it. It crashes while it’s open and running in the background in different window.


It was crashing 1-2 times daily for a few days, so I tried reinstalling. I thought that may have fixed it, but it just crashed again with the same “Anytype helper crashed” message. I have a collection of logs from pre-reinstall and one post-reinstall. I thought that everything would have been up-to-date and the same between pre/post reinstall, but figure I’ll provide as much info as I can to help.

Pre-reinstall: (4.9 KB)

crash_2023-08-24T21_11_31.log (3.9 KB)


  • Device:
    Macbook Pro 2018
  • OS:
    Ventura 13.5
  • Anytype Version:
  • Tech Info:
    OS version: darwin x64 13.5.0
    Build number: build on 2023-08-16 11:07:20 +0000 UTC from at #2815587c8afa3f81e75336226cacecb7fe105e9c(v0.27.21)
    Library version: v0.27.21
    Account ID: A8j3ze6qTHsBb3B48sSZADDdrF6YehL7E71H8kb5w2sHNE5r
    Analytics ID: d4b77e37-d253-458c-9658-5992e5b58d55
    Device ID: 12D3KooWLkLDo3axK4KNvxbeBee6J8VWd2kAHS3wCaVhLvPr7pDL

Just wanted to post a suspicion of mine. I am connected to a VPN that has periodically lost connection and I just noticed Anytype helper crashed again. I wonder if the two are related? Another thing that’s fueling this suspicion is that I have two Macbooks and only have this crashing problem recurring on the Macbook that is consistently connected to VPN.

I attached the crash log as well.
crash_2023-08-28T13_36_31.log (2.6 KB)

trouble with yamux. Thanks you for reporting

We will downgrade the golang version in the upcoming release. Please let us know if the issue goes away.
This could be problem with sync some big document or a golang runtime issue.
Also we try to modify code in the upcoming release or in one after that

1 Like

Seems this is this issue


Good find! I’ll check in after the next update.

Let me know if there’s anything else I can do to help with this issue.

EDIT: Confirming this seems to have squashed the bug!

1 Like