Anytype has another instance running

Description
After a crash (for unknown reasons, computer was in sleep mode), Anytype believes there is another instance of Anytype running and produces an error message at startup. It says “Closing…” but does not close any other process that may be running. There is no obvious signs another process is running to the average user.

Investigating, I found that a renderer helper process was running in the background and needed to be force-quit. (Seems it did not stop running since the program crashed).

(with a quick search I did not find this issue reported)

To Reproduce
Steps to reproduce the behavior:

  1. A crash may be necessary, or some sort of unexpected quit
  2. Attempt to open Anytype
  3. Anytype will close itself…
  4. Activity monitor may indicate a background process is still running

Expected behavior
Perhaps Anytype could attempt to determine whether an actual usable process is open, and force-close the background process if not.

System Information:

  • OS: Mac OS X Monterey (ver. 12.1)
  • Device Manufacturer/Model: Apple iMac (M1 Chip, 2021)
  • Anytype Version: 0.23.5

@LifeHasLeft HI! Could you send us the log file? You can find logs directory in your anytype folder

@LifeHasLeft Did this happen to you again in the latest releases?

Happened to me last night.

Anytype Version 0.25.4.
MacOS 12.3.1

Exact same behavior as reported earlier. But the log folder is unfortunately empty.

Please send your logs to support@anytype.io and mention this topic in your mail.