Anytype doesn't start and thereafter cannot be closed

Describe the bug
When I try to start Anytype it does not open properly. I see the launching screen (?) when the logo appears and log-in screen (?). After that a white screen is displayed. Furthermore, Anytype is not closable, it can only be shotdown. I tried every button in the menu bar and “About Anytype” surprisingly works, every other button doesn’t.

To Reproduce

  1. Open Anytype (on my machine - I’d like to try it with a clean installation, but don’t know how to uninstall properly)

Expected behavior
Anytype should start, log in and be ready. In case of problems it should be possible to close and reboot the application.
To fix problems I should be able to find log files and uninstall/delete all files/reinstall the application.

System Information:

  • OS: MacOS Monterey (OpenCore Legacy Patcher)
  • Device: MacBookPro early 2013
  • Anytype Version: 0.24 and 0.25.4 (tried upgrading to fix)

Additional context
I understand that Monterey is not supported on my MacBook. Despite that, it is powerful enough to run notetaking-software, especially to enhance longevity of hardware. I’m willing to put some effort into it to make it work.
I would like to post more concise reports, but I cannot find any log files. I tried to reinstall Anytype, but I’ve found no explanation on how to uninstall it.

In summary, I’d like to receive an instruction on how to reinstall Anytype from scratch, in order to ensure that this is a reproducible bug.

Hey everyone,

so I fixed it by deleting my Anytype folder under /Users/User/Library/Application Support/anytype2 using this
Sync problems, White screen or not responding, high resource consumption article.
Changing the settings to debug mode via console just did not work for me.

I hope it might help someone out there - otherwise this is a dumb post :frowning:

1 Like