Anytype creates a new page but the new page is NOT empty

Describe the bug
Anytype creates a new page but the new page is NOT empty.

To Reproduce
Steps to reproduce the behaviour:

  1. (as you can see in the video) I typed a ‘/’.
  2. Then I typed “page”.
  3. I pressed the “Enter Key”.
  4. A new page was created but it’s NOT empty.

Expected behaviour
Anytype must create an empty page. Like it used to do before.

System Information:

  • OS: Ubuntu 20.04.4 LTS
  • Device Manufacturer/Model: ASUS K540 UB
  • Anytype Version: 0.26.1

Additional context
This behaviour happened when after I did something.
I had a markdown file which was not from Notion. I just thought that when markdowns from Notion are accepted, maybe that markdown gets accepted too. So I did this: File → Import → Notion → Import data and I chose my markdown (Even though the markdown was not from Notion, Sorry). And nothing happened, and no progress bar appeared. And after some time I wanted to turn off my laptop. But Anytype didn’t get closed. So I had no choice but to turn off my laptop despite the fact that Anytype is not closed. The problem I’m reporting happened after this event.

@Haieri thanks for posting! Could you check whether you have edited the template in Anytype for the Page Object type?

  1. Open Anytype on the desktop and open the Library
  2. Locate the Page type under the Types
  3. See whether a template is defined

If so, check whether the contents of that template match what you see whenever you make a new page. If that is the case, you are seeing the intended behavior. If not, you found a bug!

2 Likes

Dear @sambouwer, Thank you for being a valued member of Anytype community.

I checked what you wrote. You were correct. And also the context did match.
Despite the fact that I haven’t ever created a template for pages, there was a template.
I deleted that and now my problem is solved.

Thanks for your assistance.

2 Likes

Thanks for the quick check and confirmation, and happy to help!

Could it be that at any point in time you (by accident?) clicked the "use as template option?

image

This takes the current instance (=Object) of an Object Type and saves it as a Template. You can test this yourself:

  1. Create a new Object of any kind of Object Type. Click “Open type”
    image
  2. See whether there are any Templates saved for your Object Type
  3. Go back to your Object
    image
  4. Click “Use as a template”
    image
  5. Notice how the Object Type now says “template”
    image
  6. Go back to your Object Type and see that there is now one (more) Template saved
2 Likes

Thanks for clear steps you replied. I checked them.

The way you mentioned for creating and seeing templates worked for me.

And as you said, I may “accidentally” have pressed the “Use as a template” option, because I can’t remember I have done that intentionally.

I appreciate your help. Thank you.

2 Likes