Anytype crashing - 'ANYTYPE HELPER CRASHED'


Anytype is crashing everytime I start using it, after a few seconds. The error message is always: ‘anytype helper crashed’


  • OS:
    Windows 11 Pro
  • Device:
    msi prestige laptop
  • Anytype Version:


I already reinstalled it and it keeps happening.
It all started around 10 days ago.


This report has been added to our issue tracker and received by the Development Team.

@_An is this still occurring? It would be helpful if you can add the .log file to your topic.


Hi Angelo, thanks for your follow up.

Yes, unfortunately it is still occurring. I’m uploading the LOG file here (from today)
crash_2023-02-16T16_05_43.log (2.3 KB)

I don´t know if it is related to this issue but a few weeks ago I started to have problems with a SET of TASK objects. Once I opened a SET from my iphone app, it was not available anymore on my PC so I have to create a new one and the same happened again a couple of days later. I made a 3rd version of the SET but now I can’t use ANYTYPE from my PC, and if I open it from the iphone app, the 3rd version of the SET of TASKs is there, but the TASKS itself are not in sync with the PC (for example many of the completed ones a long time ago, appear uncompleted).

I used ANYTYPE for weeks with this same structure and it all worked perfectly on the PC with the apps syncing not being good. But now on the PC, it crashes every time.

1 Like

My Helper is crashing too.

I noticed that some of the new items added on another device have not synced across. I couldn’t find them at all.

Now it is crashing everytime i click on the app icon.

crash_2023-02-23T21_47_18.log (7.0 KB)

Will try reinstalling now.

1 Like

Thanks @_An I updated the issue with your logs.

@CodeKnight I added yours as well.

Yes, please try this and report back.

Thanks to you both!

Reinstalling it has fixed the issue, however i am hesitant to update to the latest version. As this issue seemed to begin when i updated.


Just keep the version which is most stable handy, and back up your Anytype2 folder:
File>Show Work Directory

We will begin rolling out our new infrastructure in the next versions, so no reason to stave off the inevitable. :zap:

crash_2023-03-01T17_15_17.log (6.9 KB)

i upgraded to the latest version, and the crashing has begun again. On trying to open anytype i get the following error.


1 Like

Is this happening repeatedly? Can you restart your system and try again?

Yes, repeatedly, and still occurs after restart. Only happens on the latest version, if i don’t upgrade it works fine.
0.31.0 - Crashes
0.30.0 - No Crashes

Let me know if you need any other info.

1 Like

@CodeKnight @_An

Please see this post:

Hi Angelo,

Today, I updated all the apps in windows and both android and iphone phones I use, to the latest version. Unfortunately it keeps crashing.

I tried to make a dump of Anytype following your message but my browser can’t open the http://127.0.0

Anyway, I’m attatching a PDF from the CMD prompt as far as i could copy. You cannot see the lines when began running Anytype, but the last page is right where it crashed.

from CMD.pdf (647.2 KB)


Thanks @_An

To make sure I got you right, were you able to complete the steps described for Windows?

Yes 100% sure I followed the steps.

Anyway, from the windows task manager I created the dump files of all 4 Anytype’s processes running when it crashed. Find them attached in case that helps.
From the same crash, I’m sending a screenshot of the CMD PROMPT when it began running Anytype and a PDF containing the last lines running before Anytype crashed ( this is a long as you can see from the CMD prompt )

CMD PROMPT LOG CRASH V3.pdf (632.5 KB) (566.2 MB)

1 Like

Hi, i have the same issue (Windows10) about months.
Even after update and reinstalling the last version. I already send the logs to e-mail support, but no responses.
I stop to try this app, but i like to return.
In attachment the most recently log file.
crash_2023-03-26T12_51_07.log (1.5 KB)

Hi @egfguedes, welcome to the Community.

To which email have you sent them?

I have received only one email from you, from Oct 12, asking if you could skip the onboarding session. I responded within an hour, and gave all the necessary details to start using Anytype, and advised to report bugs in the Community.

Thanks for sharing your log, I will add it to the internal issue.

I’m sorry you’ve experience this difficulty, the good news is the next release will be without libp2p, so this issue will be resolved. :sparkles:

Hi Angelo, thanks for the welcome and the instructions!

I really couldn’t attend the session due to time compatibility. But I would like it when possible.

I emailed the logs to: four times between October and December.

I look forward to the next release. :slight_smile:

Thank you!

1 Like

Happy to have you! Understandable about the onboarding sessions, we are preparing more onboarding materials this year. If you want I can provide you a recording of a previous one, just shoot me a message

Go it, I was afraid of that. This prompt was removed quite some time ago, and the devs do not monitor this email. You can disregard it, going forward. :laughing:

In the latest versions, Testers are now directed to the Bug Reports category here in the Community. It’s the only place to submit bugs, w/ logs etc, as it’s integrated with our internal issue tracker and reports are sent directly to the responsible teams. :mountain_cableway:

1 Like

thank you, i will send a email.

No problem, thanks for explanation.

there´s a older version that can i use without this bug until next release?

1 Like