Android start up time is slow

Describe the bug

Android app takes 10 to 11 seconds to open the app. Even though there are not that many objects in it.

Previously reported it in android telegram channel to @kozlovevgenii

Expected behavior

App opening within 2 to 5 seconds

  • OS: Android 11
  • Device: Realme 8
  • Version: 0.2.6
3 Likes

As a knowledge management app Anytype Android is too slow to open. It takes around 10 second to open in Android with a relatively less content. Desktop sometimes takes time to open, showing migration.

Desired Outcome

it would be nice to see app open in 1- 3 seconds. Anytype should be relatively superhuman fast

Android version : 11

App Version: 0.2.7

1 Like

@Srinath With me it’s 3-4s in both Android 8.1.0 and Windows 10.

It doesn’t seem to depend much on amount of content. I just added around 5 objects each with a full country wikipedia page and it didn’t seem to impact opening time.

@qualquertipo this an unusal bug. I reported it in telegram. Android lead noticed it. It is not fixed yet. So i tried to fill a report.

1 Like

@Srinath You’re right to report the bug! I agree launch time should be under 4s.

1 Like

@qualquertipo Mines the same usually but i was travelling today and it took 10 sec today and as i suspected, the app opening time seems to be based on the network speed. when i’m connected to my home wifi, the app opens in 3-4 sec but on mobile data it takes around 8-12 sec

2 Likes

@lynxlove This is a good additional bit of information! It’s possible that this would change after alpha due to the change in use of “Cafe nodes” and removal of analytics. But even now it should not affect startup time, rather the app should start and only begin to deal with network operations after it has opened and is available for editing.

1 Like

@lynxlove internet speed does not seem to be the case, atleast for me.

@Srinath Interesting and good to know. It still seems worth testing as a possible factor.

You have probably reported it before somewhere, but can you please also specify your hardware?

@Oshyan reported in telegram and @kozlovevgenii he replied too. It does not fix for me.

Maybe I will try to clear Android app and see how is the load time.

Android 11

realme 8 5g

0.2.7

@Srinath roblem persist. At first with objects it loaded fast and now after with sets it is back to the original speed of 10 seconds.

The opening takes time (10 seconds) when there is a draft set with 30 objects in them.

This should provide useful info.

Duplicate of https://community.anytype.io/d/898-anytype-opening-time-is-huge-around-10-seconds. Both are raised by the same user but the later one has more conversation

1 Like

Startup speed without internet:

~ 7-10 seconds

Startup speed with internet:

~ 3-5 seconds

Additional Info:

Device: Oneplus 5T

OS: Lineage (No Gapps) Android 11

Anytype version: 0.3.1

1 Like

Startup speed without internet:

~ 7-10 seconds

Startup speed with internet:

~ 3-5 seconds

Additional Info:

Device: Infinix Note 5 Stylus

OS: Android 10

Anytype version: 0.3.1

@lynxlove Yeah, @div3xi can you merge these both?

Startup speed without internet:

~ 10-12 seconds

Startup speed with internet:

~ 5-7 seconds

Additional Info:

Device: Redmi Note 4

OS: LineageOS Android 11

Anytype version: 0.3.1

1 Like

Anytype is very slow for me, takes at least 20 seconds (100mbps internet). Quite annoying since I do like to note down any quick thoughts that pop up.

Details:
Android 12
Pixel 3a XL
Anytype version 0.4.4