After each version update, the default template of the object I set will be changed to the default blank template of the system

What’s The Bug?

After each version update, the default template of the object I set will be changed to the default blank template of the system.

How To Reproduce It

Version system update

The Expected Behavior

Version system update

Additional Context:

This question has been bothering us for a long time

Device

MacBook PRO

OS

darwin arm64 14.2.1

Anytype Version

0.37.17-beta

Technical Information

操作系统版本: darwin arm64 14.2.1
应用版本: 0.37.17-beta
构建版本: build on 2024-01-23 17:45:05 +0000 UTC at #c71c64146c6e721ac39e01d450f38db5e6963f2e
库版本: v0.30.12
Anytype 身份标识: A9vq4x7puBv19mLAdWFiAJJb24BPRxBdJkDPrM9RpoyrmQLd
分析ID: c728b0ec-7ac1-4633-afe9-7c5adfd74db9
设备ID: 12D3KooWL2VK81NiN9zuMKZATDRHfPGHDaruXYUYwVj2bVDSzEoK

Thanks for your report, I’ll check this after the next one.
Is this systematic for all the objects for which you have set another default template, or just for some?

Just so you know, Additional Context is not a mandatory field, you can skip it next time :wink:

1 Like

I had no problems switching from v37.16-beta to v37.17-beta, either with a Default Object type or a custom one. The Templates that I set by default didn’t reset to the blank one.

I’m on Windows 11, so we’d like to see someone else on macOS manage to reproduce this bug, to find out if it’s specific to this OS, or if there’s a more complex cause behind it.

1 Like

Yes, for all objects.
After each version update, I had to reset the default template

Just to confirm, this also happens with all pre-release versions? So you need to change this every time there’s a pre-release update?